Is Synchro 2017 compatable with the API for Primavera P6 V7.0?

I have been unable to connect to the P6 database and have tried everything possible for the API for version 7 (no longer listed on the downloads page) to work. I was curious if this is because they are no longer compatible.

  • Justin Gray
  • Jan 4 2018
  • FAQ
Company Hensel Phelps
  • Jan 4, 2018

    Admin Response

    Theoretically yes, Synchro 2017 is compatible with P6 v7, but the old SQL DBs compatible with P6 v7 cannot be installed under Windows 10. 

    If you are having trouble installing the API, we recommend using P6 XML files to exchange data with Synchro. Simply export the schedule from P6 as an XML, then import to Synchro via File>Import>Primavera P6: choose File for Data Source. In Synchro P6 XML files can be imported, exported, and synchronised from/to

  • Attach files
  • AhMed ElhaMrawY commented
    January 11, 2018 06:59

    what if i need to synchronize directly to synchro if there is any change happen in p6  

  • Admin
    Kate Hester commented
    January 11, 2018 11:10

    Synchronisation works with XML as well as API. Export an updated copy of the XML from P6 and go to External Data>Synchronise From (the same as if you were using the API), then choose the updated file. As long as the Task IDs are the same, the project will synchronise.

  • AhMed ElhaMrawY commented
    January 11, 2018 12:06

    @kate i will try this, i hope it works 

    thank you so much